Docker安装多版本mysql及Magento2

今天在docker中安装magento2的时候在最后一步的安装始终报错,一开始以为是数据库配置连接的错误,最后搜索了一些文档,才搞清楚原来magento2支持的版本最高是mysql5.7.xx版本,而我docker版本处于mysql8的版本,因此所有的配置是没有问题,而根原主要是在数据库版本的不支持,而最好的解决方式是降级数据库版本,问题来了,如果我要降级数据库,原来的一些数据内容有可能在5.7版本中不兼容,造成其它服务器软件无法运行,由此,便打算多版本mysql安装。

(更多…)